Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 28, 2026 - 07:01 UTC
Scheduled
Please be advised that INTERAC will be performing scheduled maintenance on Sunday, June 28th at 3:00 AM EST to 6:00 AM EST.
During the maintenance window, the service will experience approximately 60 minutes of downtime between 4:00 AM EST to 5:00 AM EST. There is a possibility that an additional downtime of 60 minutes may occur if required, but every effort will be taken to minimize this service interruption.
Thank you for your understanding
Posted Jun 24, 2026 - 18:38 UTC
This scheduled maintenance affected: Canada payment methods (Interac).