Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 22, 2025 - 07:00 UTC
Scheduled
Please be advised that our banking processor for Visa Direct will be performing scheduled maintenance on Tuesday, April 22nd at 3:00AM EST to 6:00AM EST.
During the maintenance window, the service will experience approximately 1 hour of downtime, however, every effort will be taken to minimize this services interruption.
Thank you for your understanding
Posted Apr 15, 2025 - 20:38 UTC
This scheduled maintenance affected: Canada payment methods (Visa Direct).