Please be informed that INTERAC has advised us that the technical issue you were experiencing has now been resolved. We will share a post-incident report with you as soon as we receive it from INTERAC.
Posted Nov 02, 2024 - 14:27 UTC
Identified
Interac is still facing technical difficulties that are impacting our services. We appreciate your patience during this time and will provide updates on our status page as soon as the problem is fixed. Thank you for your understanding.
Posted Nov 02, 2024 - 03:43 UTC
Investigating
Please be advised that Interac is experiencing technical issues that have caused the service to fail for some transactions. The technical teams are working to resolve this issue.