Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 21, 2024 - 07:00 UTC
Scheduled
Please be advised that our banking processor for Interac Option 2 (email/URL flow) will be performing scheduled maintenance on Thursday, November 21 at 2:00 AM EST to 5:00 AM EST.
During the maintenance window, the service may experience degradation for approximately 5 minutes, but every effort will be taken to minimize this interruption.
Thank you for your understanding
Posted Nov 20, 2024 - 21:45 UTC
This scheduled maintenance affects: Gateways (Interac).